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How To... 
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Notice 
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Preface  
Welcome to Avaya Network Configuration Manager. Avaya Network Configuration Manager is an 
application that enables you to backup and restore device configurations and configure groups of 
devices. This chapter provides an introduction to the structure and assumptions of this manual. It 
includes the following sections: 

• The Purpose of This Manual - A description of the goals of this manual. 
• Who Should Use This Manual - The intended audience of this manual. 
• Organization of this Manual - A brief description of the subjects contained in the various 

chapters of this manual. 

The Purpose of This Manual 
The Avaya Network Configuration Manager User Guide contains information needed to use 
Avaya Network Configuration Manager efficiently and effectively. 

Who Should Use This Manual 
This manual is intended for network managers familiar with network management and its 
fundamental concepts. 

Organization of this Manual 
This manual is structured to reflect the following conceptual divisions: 

• Preface - (Print version only.) Describes the manual’s purpose, intended audience, and 
organization. 

• Introduction - Provides an introduction to Avaya Network Configuration Manager, 
including information on the user interface, and instructions on changing Avaya Network 
Configuration Manager options. 

• Saving Device Configurations - Provides a description of the Device Table and 
instructions on how to manually save a device’s configuration to a file and use the 
Backup Wizard to create and manage backup jobs. 

• Downloading Configuration Files - Provides a description of the Library View, and 
instructions on how to edit a configuration file and download a file to a device. 
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Introduction 
Introduction  

This section of the on-line help provides an introduction to the Avaya Network Configuration 
Manager. It includes the following topics:  

• Avaya Network Configuration Manager Overview - An overview of Avaya Network 
Configuration Manager. 

• The User Interface - An explanation of the Avaya Network Configuration Manager user 
interface. 

• Using Tooltips - An explanation of the Avaya Network Configuration Manager tooltip 
feature. 

• The Log - A description of the Avaya Network Configuration Manager log. 

• Setting Avaya Network Configuration Manager Options - Instructions on setting 
Avaya Network Configuration Manager options. 

• Generating Reports - Instructions on generating Avaya Network Configuration Manager 
reports. 

• Searching the Device or Library Table - Instructions on searching Avaya Network 
Configuration Manager tables. 

• Comparing Configuration Files - Instructions on comparing configuration files in Avaya 
Network Configuration Manager. 
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Avaya Network Configuration Manager Overview  
Avaya Network Configuration Manager is an application that allows you to backup and restore 
device configurations and configure multiple devices. Avaya Network Configuration Manager 
uses Simple Network Management Protocol (SNMP) and Trivial File Transfer Protocol (TFTP ) or 
Secure Copy Protocol (SCP) to exchange information with the devices in the network.  

When using SCP, an SCP server must be installed on the management station. After defining 
users on the SCP server, you can configure Avaya Network Configuration Manager as an SCP 
user.  

When you make changes to a device's configuration, you may find that the overall effect of the 
configuration change may have a negative effect on the performance of the device in your 
network. Avaya Network Configuration Manager provides a method for backing up device 
configurations before you make changes. In addition, you can schedule automatic, periodic 
backups.  

Device configurations are saved in files which are stored in a library. A configuration file can be 
downloaded to any appropriate device. For example, if you saved the configuration of an Avaya 
P580 Device, it can only be downloaded to an Avaya P580 Device. You can also select a group 
of devices to which you can download a single configuration file. This can result in a consistent 
configuration of the devices in your network.  

 Note: 

In this documentation, 'uploading' always refers to information being copied from 
the device to the application, and 'downloading' always refers to information being 
copied from the application to devices. 
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The User Interface 
The User Interface  
The user interface consists of the following elements:  

• Menu Bar - Menus for accessing Avaya Network Configuration Manager's functions. 
• Toolbar - Toolbar buttons for accessing Avaya Network Configuration Manager's main 

functions. 
• View Tabs - Tabs for switching between Download View and Library View. 
• The Table Area - An area where the Device Table and Library Table open. 
• Dialog Area - A window where all dialog boxes are displayed. When no dialog box is 

open, the Dialog Area disappears, and the Device Table expands to take its place. 
• Status Line - An area at the bottom of the window where the communication status 

between Avaya Network Configuration Manager and network devices and other 
information is displayed. 
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Avaya Network Configuration Manager Menus  
The following menus are available in Avaya Network Configuration Manager.  

File Menu  

Item Description 

Report Opens the Report dialog box. 

Options Opens the Options dialog box. 

Compare Opens the Compare dialog box. 

 

Edit Menu  

Item Description 

Editor Opens the configuration file editor. 

Delete Deletes the selected row or rows from the table. 

Find Opens the Find dialog box. 

 

View Menu  

Item Description 

Tooltip Enables tool tips in the table. 

Log Opens the log. 

Filter Opens the Filter Devices dialog box. 
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Actions Menu  

Item Description 

Detect Devices Rediscovers the information in the Device Table. 

Upload Opens the Upload Configuration dialog box. 

Download Opens the Download Configuration dialog box. 

Jobs Opens the Jobs dialog box. 

Backup Starts the Backup Wizard. 

Restore Starts the Restore Wizard. 

 

Tools Menu  

Item Description 

Device Manager Launches the device manager for the selected device. 

 

Help Menu  

Item Description 

Contents Opens the help system at the Table of Contents. 

Help On Opens the help topic for the currently displayed screen or dialog box 
(context sensitive help). 

About Avaya 
Configuration 
Manager 

Opens a window containing copyright and release information about 
Avaya Network Configuration Manager. 
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Toolbar  
The Toolbar provides shortcuts to the main Avaya Network Configuration Manager functions.  

The table below describes the buttons on the Toolbar and gives the equivalent menu options. 

 

Icon Tooltip Description Menu Item 

 Generate Report Opens the Report dialog box. File > Report 

 General Options Opens the Options dialog box. File > Options 

 Compare Opens the Compare dialog 
box. 

 

File > Compare 

 Edit Configuration Opens the specified 
configuration file editor. 

Edit > Editor 

 Delete Files Deletes the selected row or 
rows from the table. 

Edit > Delete 

 Locate Item Opens the Find dialog box. Edit > Find 

 Show Log Opens the log. View > Log 

 Detect Devices Rediscovers the information in 
the Device Table. 

Action > Detect Devices 

 Upload From 
Device 

Opens the Upload 
Configuration dialog box. 

Action > Upload 

 Download To 
Device 

Opens the Download 
Configuration dialog box. 

Action > Download 

 Scheduled Jobs Opens the Jobs dialog box. Action > Jobs 

 Start Backup 
Wizard 

Starts the Backup Wizard. Action > Backup 

 Restore Wizard Starts the Restore Wizard. Action > Restore 

 Launch Device 
Manager 

Launches the device manager 
for the selected device 

Tools > Device Manager 

 Context Sensitive 
Help 

Opens the help topic for the 
currently displayed screen or 
dialog box (context sensitive 
help). 

Help > Help On 
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View Tabs  
The View Tabs are used to switch between the two views in the Table Area. Click the View Tab 
for the table you wish to view.  

• Backup Tab - Displays the Device Table. These are the individual devices that can be 
backed up. 

• Restore Tab - Displays the Library View. This is the library of files that can be restored to 
the devices. (Files can be restored to devices of the same type, not to just the original 
device from which they were backed up.) 
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The Table Area  
The Table Area is where devices and configuration files are displayed. There are two views 
available in the Table Area:  

• The Device Table - (Backup tab) - Lists devices in the network . 
• The Library View - (Restore tab) - Lists configuration files in the library. 

 

To select an item in a table row, click anywhere in the row.  

 

To select a contiguous group of rows:  

1. Click the row at the top or bottom of the group. 

2. Press SHIFT, and click the row at the other extreme of the group. The two end rows and 
all of the rows between them are selected. 

 

To select multiple rows that are not contiguous:  

1. Click one of the rows. 

2. Press CTRL, and click additional rows you want to select. 

To sort a table by one of its columns, click the column header. To reverse the order of the sort, 
click the column header again.  

The Device Table  
The Device Table lists devices in the network and displays information about them. The Device 
Table is used for uploading configurations from devices and saving the configurations to files in 
the library.  

The Device Table displays the following information about each device:  

• Name - Name of the device (as known to Avaya Network Configuration Manager). 
• IP - IP address of the device. 
• Module - The slot in which the module is located in the device. For stackable devices, 

this is the module's position in the stack.  
• Type - The type of device. 

• Last Operation - The last configuration operation performed on the device. Options are:  

¡ Upload - The device's configuration was uploaded manually.  

¡ Backup - The device's configuration was uploaded using an immediate backup.  

¡ Backup:<Job Name> - The device's configuration was automatically uploaded 
by the <Job Name> periodic backup job.  

¡ Download - A configuration file was downloaded manually to the device.  

¡ Restore - A configuration file was downloaded using an immediate restore. 

¡ Restore:<Job Name> - A configuration file was automatically downloaded by the 
<Job Name> restore job. 

• Time - The date and time at which the last operation occurred. 
• By - The owner of the last operation. 
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For further information on using the Device Table to upload configurations, refer to Saving Device 
Configurations.  

The Library View  

The Library Table lists the configuration files in the library. The Library Table is used for 
downloading configurations to appropriate devices.  

The Library Table displays the following information about each file in the library:  

• Name/Desc - Name of the device (from the platform) from which the file was uploaded. 
• IP - IP address of the device from which the file was uploaded. 
• Module - The slot in which the module is located in the device from which the file was 

uploaded. For stackable devices, this is the module's position in the stack.  
• Device Type - The type of device. 
• Software - The software version running on the device at the time of the file creation. 

• File Type - The file type. Indicates whether the file is a Running Configuration file or a 
Startup Configuration file. 

• Job Name - The name of the job that created the configuration file. 
• Time - The date and time at which the configuration file was created or last modified. 
• Created By - The source of the configuration file. Options are:  

¡ Upload - The configuration file was created by an immediate backup job.  

¡ Edit - The configuration file was created or modified using the File Editor.  

¡ Unknown - The source of the configuration file is unknown.  

• User - The name of the person who created or last modified the configuration file. 
• File - The command line interface (CLI) name of the configuration file. 

 
For more information on the Library View, refer to Using the Library View.  



Avaya Network Configuration Manager On-Line Help Printout 

16 

Dialog Area  
The area to the right of the Table Area is where all dialog boxes appear. This area can be resized 
by dragging the vertical splitter bar with the mouse. When a dialog box opens, it replaces the 
current dialog box in the Dialog Area. When no dialog box is open, the Dialog Area disappears, 
and the Table Area window expands to take its place.  
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Status Line  
The Status Line shows the following:  

• Left - A message specifying whether or not the table is being filtered. 
• Center: 

o The progress of uploads and downloads. 
o When a configuration file is selected, the file type, the IP address and module 

number of the device from which the file was uploaded, and the date the file was 
created or last modified. 

• Right - A status message and graphic displaying the communication status 

between Network and the devices on the network. 

The table below shows the possible communication statuses with their corresponding 
graphics, and gives a short explanation for each status. 

 

Message Graphic Description 

<current or final 
status of last 
operation>  

Avaya Network Configuration Manager is 
ready and no upload/download activity is 
currently in progress. (May be discovering 
devices.) 

<Uploading or 
Downloading> 

 
(animated) 

Avaya Network Configuration Manager is 
uploading or downloading configuration files 
to or from devices. 
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Using Tooltips  
Avaya Network Configuration Manager includes a tooltip feature that allows you to display 
additional information about devices and software versions. Tooltips are available in the following 
places:  

• Device View - To display additional information about a device, place the cursor 
anywhere on the device's row. After about one second, a tooltip appears with information 
about the device. The following information displays: 

o Device Name - Name of the device (as known to Avaya Network Configuration 
Manager). (From the Name column of the Device Table.) 

o Device IP - IP address of the device. (From the IP column of the Device Table.) 
o Module Number - The slot in which the module is located in the device. For 

stackable devices, this is the module's position in the stack. (From the Module 
column of the Device Table.) 

o Version - The software version running on the device at the current time. 
o Last Operation - The last configuration operation performed on the device. 

(From the Last Operation column of the Device Table.) 

 

• Library View - To display information about a configuration file, place the cursor over a 
configuration file in the Library View. After about one second, a tooltip appears with 
information about the selected configuration. The following information displays: 

o File Name - The command line interface (CLI) name of the configuration file. 
(From the File/Desc column of the Library Table.) 

o Version - The software version running on the device at the time of the file 
creation. 

 

 

To toggle the status of the tooltips feature, select View > ToolTip.  
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The Log  
Avaya Network Configuration Manager keeps a log of all activity. New log information is 
appended to the end of the existing log. When you close Avaya Network Configuration Manager, 
the log is erased.  

To view the log, select View > Log or click the  (Show Log) button on the Toolbar. The Log 
window opens. 

 

The following table provides a list of the fields in the log and their descriptions. 

 

Field Description 

Severity The severity of the event, as follows:  

• Normal - A successful action, such as a completed upload or 
download. 

• Warning - An unsuccessful action, such as failure to discover a 
device. 

• Major - An event relating to a failure to upload or download to a 
device. 

• <blank> - An information message. 

Date The date and time at which the event occurred. 
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Field Description 

Source The source of the event. Possible sources include: 

• IP Address (Device) - The source is the device with the specified IP 
address. 

• IP Address (Module Number) - The source is the specified module 
number in the device. 

• Library - The source is the Avaya Network Configuration Manager 
library. 

Message A description of the event.  

 

To clear all of the entries in the log, click Clear. The log is cleared.  

 

To refresh the entries in the log, click Refresh. The log is refreshed.  

 

To close the log, click . The Log Window closes.  
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Setting Avaya Network Configuration Manager 
Options 

Setting Avaya Network Configuration Manager Options  
Using the Options dialog box, you can configure Avaya Network Configuration Manager options. 
The General tab of the Options dialog box enables you to configure the default downloading 
action and the report type and path. The tab of the Options dialog box enables you to configure 
the protocol to use for transferring files.  

• General Tab 
• File Transfer Protocols Tab 
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General Tab  
To open the Options dialog box to the General tab: 

Click the  (General Options) button on the Toolbar 

Or 

Select File > Options. The Options dialog box opens to the General tab. 

 
Using the General tab of the Options dialog box, you can:  

• Select a Report Location (Default Report Path) 
• Select a Report Format (Format of Report File) 
• Set the Default Action When Downloading 

• Set the Program Used for Comparing Files (Path to Diff Program) 

To undo all changes made in the Options dialog box before they are applied, click Refresh. All 
unsaved changes to the dialog box are discarded.  

Select a Report Location  

Avaya Network Configuration Manager reports are saved on the computer from which the 
application is run. If you are running Avaya Network Configuration Manager via remote access, 
reports are saved on the client computer, not the server.  

To select a directory to which Avaya Network Configuration Manager reports are saved:  

1. Click ... in the Default Report Path section of the Options dialog box. A directory browser 
opens. 

2. Browse to the directory in which you want Avaya Network Configuration Manager to save 
reports. 

3. Click OK. The directory browser closes. 

4. Click Apply. Avaya Network Configuration Manager saves reports to the selected 
directory. 

Select a Report Format  
Avaya Network Configuration Manager can create text reports in one of these formats:  

• CSV (Comma Separated) - The information in the table rows are separated by commas. 
• Tab Delimited Format - The information in the table rows are separated by tabs. 

To select a format for Avaya Network Configuration Manager reports:  

1. Select the desired report format from the Format of Report File pull-down list box. 
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2. Click Apply. The report format is configured. 

Set the Default Action When Downloading  
You can configure the default response of Avaya Network Configuration Manager when a 
download is going to start. The possible actions are:  

• Request Confirmation - A confirmation dialog box opens asking you to confirm the 
download. 

• Do Not Request Confirmation - Avaya Network Configuration Manager will start the 
download without requesting confirmation. 

To configure the default action when downloading:  

1. Select the desired default action from the Default Action When Downloading pull-down 
list box. 

2. Click Apply. The default action when downloading is configured. 

Set the Program Used for Comparing Files  
Avaya Network Configuration Manager enables you to compare configuration files between 
similar devices, or between different versions on the same device. This capability requires 
defining the software used to display the differences in the configuration files.  

To select a directory with the location of the software for Avaya Network Configuration Manager 
to use for comparing files:  

1. Click ... in the Path to Diff Program section of the Options dialog box. A directory browser 
opens. 

2. Browse to the directory with the software you want Avaya Network Configuration 
Manager to use to compare files. 

3. Click OK. The directory browser closes. 

4. Click Apply. Avaya Network Configuration Manager sets the chosen software for 
comparing configuration files. 
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File Transfer Protocols Tab  
Using the File Transfer Protocols tab of the Options dialog box, you can configure the protocols 
used for transferring files with Avaya Network Configuration Manager.  

To open the Options dialog box to the File Transfers Protocol tab: 

1. Click the  (General Options) button on the Toolbar. 

Or 

Select File > Options. The Options dialog box opens to the Options tab. 

2. Click File Transfer Protocols. The File Transfer Protocols tab of the Options dialog box 
appears. 

 
The following table provides a list of the fields in the File Transfer Protocols tab of the Options 
dialog box and their descriptions. 

 

Field Description 

SCP Global Use  The state of SCP usage for Avaya Network Configuration Manager. 
Possible values:  

• Enabled - SCP is used for devices that support SCP. Devices 
that do not support SCP use FTP if FTP Global Use is 
enabled, otherwise TFTP is used. 

• Disabled - SCP is not used. FTP is used for all devices if FTP 
Global Use is enabled, otherwise TFTP is used. 
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Field Description 

SCP User Name  A user name defined on the SCP server. This is the SCP user that 
Avaya Network Configuration Manager will use. 

SCP Password  The password defined on the SCP server for the configured SCP user. 

Retype SCP 
Password  

The password defined on the SCP server for the configured SCP user. 
The password is entered twice to ensure that it is entered correctly. 

SCP Server Secure 
Path 

The path to the root of the secure path configured on the SCP server.  

FTP Global Use The state of FTP usage for Avaya Network Configuration Manager. 
Possible values: 

• Enabled - If SCP is disabled, or SCP is not supported, then 
FTP is used for devices that support FTP. Devices that do not 
support FTP use TFTP. 

• Disabled - FTP is not used. If SCP is disabled, or a device 
does not support SCP, then TFTP is used. 

 

FTP User Name A user name defined on the FTP server. This is the FTP user that 
Avaya Network Configuration Manager will use. 

FTP Password The password defined on the FTP server for the configured FTP user. 

Retype FTP 
Password  

The password defined on the FTP server for the configured FTP user. 
The password is entered twice to ensure that it is entered correctly. 

FTP Server Path  The path to the root of the secure path configured on the FTP server. 

TFTP Server Secure 
Path  

The path to the root of the secure path configured on the TFTP server.  

   

To apply the changes made in the File Transfers Protocol tab of the Options dialog box, click 
Apply.  

 

To undo all changes made in the Options dialog box before they are applied, click Refresh. All 
unsaved changes to the dialog box are discarded.  
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Generating Reports  
Avaya Network Configuration Manager can generate the following reports:  

• Library Report - A report listing the configuration files stored in the library. (This 
information can be viewed in the Library Table.) 

• Scheduled Jobs Report - A report listing scheduled backup jobs. (This information can 
be viewed in the Jobs dialog box.) 

• Last Operations Report - A report listing the last upload/download operation on each 
device in the Device View. (This information can be viewed in the Device Table.) 

Reports are saved as text files, with the fields in each item separated by commas or tabs. For 
more information on configuring report options, refer to General Tab.  

 Note: 

Reports are saved on the computer from which the application is run. If you are 
running Avaya Network Configuration Manager via remote access, reports are 
saved on the client computer, not the server.  

 

To generate a report:  

1. Click the  (Generate Report) button on the Toolbar 

Or  

Select File > Report. The Report dialog box opens.  
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2. Select a Report Format. For more information on report formats, refer to Select a Report 
Format. 

3. Select a Report Type. (See definitions above.) 

4. Enter a name for the report in the Report File Name field. 

5. Click OK. The selected report is generated and saved to the specified file. 
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Searching the Device or Library Table  
You can search the Device Table to find a device or the Library Table to find a configuration file. 
When searching for a device, you can search using the device's Name or IP address. When 
searching for a configuration file, you can search using the Name or IP address of the device 
from which the file was uploaded.  

 

To search the Device or Library Table:  

1. Click the View Tab to open the table you wish to search. 

2. Click the  (Locate Item) button on the Toolbar 

Or 

Select Edit > Find. The Find dialog box opens. 

 
3. Do one of the following:  

¡ To find a device or configuration file by IP address: 

a. Click the Find by Device IP option button. 

b. Enter the device's IP address. 

¡ To find a device or configuration file by name: 

a. Click the Find by Device Best Name option button. 

b. Enter the device's name. 

4. Click Find. The device or file is highlighted in the table. 
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Comparing Configuration Files  
This section explains how to compare configuration files with Avaya Network Configuration 
Manager. You can compare configuration files between similar devices listed in the Device Table, 
or between a current configuration file and a saved configuration.  

 Note: 

Files for devices used by Avaya Distributed Office cannot be compared as they are 
encrypted. The Toolbar Compare button and the Tools > Compare menu options 
are disabled for these devices. 

 

To compare configuration files:  

1. Select a device in the Device Table that contains a file you want to compare.  

 Note: 

You can also select both devices to compare from the Device Table, where 
the device which appears higher in the Device Table is considered the first 
device selected. You can re-sort the Device Table according to the device 
order needed. When choosing files by selecting both devices from the 
device table, perform step 2 followed by step 8. 

2. Click the  (Compare) button on the Toolbar 

Or  

Select Tools > Compare. The Compare Configurations dialog box opens.  
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3. Select a device in the Device Table that contains a file you want to compare. 

4. Select the type of file to be compared for the selected device on the Compare on device 
drop-down list box in the Compare Configurations dialog box. The possible files for 
comparison changes according to the device type selected. 

5. From the With drop-down list box select to compare this file with a different device's 
configuration file, or from a saved version of the configuration file. 

6. Select the file type with which to compare the selected file from the Configuration on 
device drop-down list box. The possible files for comparison changes according to the 
device type selected. 

7. Select the device with the file for comparison from the table on the Compare 
Configurations dialog box. 

8. Click Compare. Avaya Network Configuration Manager compares the selected 
configuration files and opens the result in the software selected for file comparison. For 
more information on selecting the file comparison software, refer to Set the Program 
Used for Comparing Files. 

 Note: 

You must define the path to the program used to compare the files in the Options 
dialog box, General tab. If the "Diff" program is not defined, you will get an error 
message. 
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Saving Device Configurations 
Saving Device Configurations  

This section of the on-line help explains how to save device configurations. Avaya Network 
Configuration Manager enables you to manually save the configurations of selected devices and 
to create backup jobs for automatically saving the configuration of all or some of the devices 
listed in the Device Table. The Device Table lists discovered devices and displays information 
about them.  

This section of the on-line help includes the following topics:  

• Using the Device Table - Describes the Device Table and its fields, and explains how to 
use the Device Table. 

• Saving a Device Configuration - Instructions on how to manually save a device's 
configuration to a file. 

• Creating a Backup Job - Instructions on using the Backup Wizard, including an 
explanation of each of the wizard's screens. 

See Also 
• Managing Jobs - Instructions on how manage jobs created by the Backup Wizard or the 

Restore Wizard. 
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Using the Device Table  
This section describes the information in the Device Table and the Device Table's functions. It 
includes the following topics:  

• Information Displayed in the Device Table - Explains the information displayed in the 
various columns of the Device Table. 

• Filtering the Device Table - Explains how to filter out devices in the Device Table. 

Information Displayed in the Device Table  
The Device Table displays the following information about each device:  

• Name - Name of the device (as known to Avaya Network Configuration Manager). 
• IP - IP address of the device. 
• Module - The slot in which the module is located in the device. For stackable devices, 

this is the module's position in the stack.  
• Type - The type of device. 

• Last Operation - The last configuration operation performed on the device. Options are:  

¡ Upload - The device's configuration was uploaded manually.  

¡ Backup - The device's configuration was uploaded using an immediate backup.  

¡ Backup:<Job Name> - The device's configuration was automatically uploaded 
by the <Job Name> periodic backup job.  

¡ Download - A configuration file was downloaded manually to the device.  

¡ Restore - A configuration file was downloaded using an immediate restore. 

¡ Restore:<Job Name> - A configuration file was automatically downloaded by the 
<Job Name> restore job. 

• Time - The date and time at which the last operation occurred. 
• By - The owner of the last operation. 

Filtering the Device Table  
You can filter the Device Table in order to reduce the number of devices currently displayed. This 
can make it easier to work by eliminating devices from the display. You can later add these 
devices back to the list by removing the filter, without having to re-discover the devices.  

When filtering, you can select: 

• Devices by name, IP address, or group.  

• Families of devices and specific module types. Under each product family name, one or 
more module types are listed. To display module types, click the handle next to the 
product family.  

When you select a product family, all the module types are automatically selected. You 
can then clear any module types that you do not want to select.  
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To filter the Device Table:  

1. Select Actions > Filter. The Filter dialog box opens. 

 
2. To filter by Select Criteria, enter the Device Name and/or IP address and/or select a 

group from the Select Group drop-down list. 

3. To filter by Device Type, check the checkboxes of the device and modules types you 
want to see in the Device Table. Clear the checkboxes of the device and module types 
you do not want to appear in the Device Table. To select all device and module types, 
check All. 

4. Click Apply. The filter is activated and the dialog box closes. 

When the filtering criteria are active,  appears in the Status Line.  
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Saving a Device Configuration  
To save a device's configuration to a file in the library:  

1. Select a device in the Device Table. 

 Note: 

You can upload the configurations of several devices by selecting them 
before you open the Upload dialog box. 

2. Click the  (Upload From Device) button on the Toolbar 

Or  

Select Actions > Upload. The Upload dialog box opens displaying one row for each 
configuration type found in the selected device. 

 

3. Select the configuration types you want to upload. 

4. Click Upload. A progress bar appears above the Upload button, and the upload begins.  

The progress bar next to each configuration type shows the progress of the upload of that 
configuration. The progress bar that appears above the Upload button shows the progress of the 
entire upload.  
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Creating a Backup Job  
The Backup Wizard provides a simple method of backing up the configurations of all or some of 
the devices in your network. In addition, using the Backup Wizard, you can schedule periodic 
automated backups. This can help you maintain an archive of your devices' configurations over 
time. The Backup Wizard also enables you to edit existing backup jobs.  

 Note: 

If you configure a backup job from a workstation working via remote access, the 
backup files are saved on the server. 

• Activating the Backup Wizard 

• Backup Wizard Screens 

Activating the Backup Wizard  
To create a new backup job:  

Click the  (Start Backup Wizard) button on the Toolbar  

Or  

Select Actions > Backup.  

Or  

Click New in the Jobs dialog box. The Backup Wizard opens with the Backup Wizard - 
Welcome Screen.  

To edit an existing backup job:  

1. Select a backup job in the Jobs dialog box. 

2. Click Edit. The Backup Wizard opens with the Backup Wizard - Device Selection 
Screen. The parameters of the selected backup job appear in the Backup Wizard 
screens. 

Backup Wizard Screens  
This section provides detailed information on each of the Backup Wizard's screens. To accept the 
default options for any screen, click Next. To return to an earlier screen, click Back. To exit the 
Backup Wizard without making any changes, click Cancel.  

The following sections describe each of the Backup Wizard screens.  

• Backup Wizard - Welcome Screen 
• Backup Wizard - Device Selection Screen 

• Backup Wizard - File Type Screen 
• Backup Wizard - Job Type Screen 
• Backup Wizard - Job Name Screen 
• Backup Wizard - Period Parameters Screen 
• Backup Wizard - Summary Screen 
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Backup Wizard - Welcome Screen  
The Backup Wizard provides a simple method for backing up the configurations of devices in your 
network .  

 
To continue, click Next. The Backup Wizard continues with the Backup Wizard - Device 
Selection Screen.  

 

Backup Wizard - Device Selection Screen  
The Device Selection screen of the Backup Wizard, enables you to determine which device 
configurations to backup.  

 



Saving Device Configurations 

37 

To determine the devices whose configurations to backup, select one of the option buttons. The 
options are:  

• Selected Devices - Only the configuration of the devices selected in the Device Table 
are backed up. 

• All Devices - The configuration of all devices shown in the Device Table are backed up. 

 Note: 

When All Devices is selected, only the configurations of devices currently 
displayed in the Device Table at the time of the backup job are backed up. 

When you have selected a method for device selection, click Next. The Backup Wizard continues 
with the Backup Wizard - File Type Screen.  

 

Backup Wizard - File Type Screen  

The File Type screen of the Backup Wizard enables you to select the configuration types to 
backup. The File Type screen displays the configuration types for each device that will be backed 
up.  

 

Select the configuration types you want to back up. To select or deselect a configuration type, 
click on the row displaying the configuration type.  

When you have selected the configuration types to backup, click Next. The Backup Wizard 
continues with the Backup Wizard - Job Type Screen.  
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Backup Wizard - Job Type Screen  
The Job Type screen of the Backup Wizard enables you to determine whether the current backup 
will be performed once or periodically.  

 

To determine the job type, select one of the option buttons. The options are:  

• Immediate - The current backup is performed once, and the backup job's options are not 
saved. 

• Periodic - The current backup will be performed at user defined periods, and the backup 
job's options are saved. 

When you have selected a job type, click Next. If you selected Immediate, the Backup Wizard 
continues with the Backup Wizard - Summary Screen. If you selected Periodic, the Backup 
Wizard continues with the Backup Wizard - Job Name Screen.  
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Backup Wizard - Job Name Screen  
The Job Name screen of the Backup Wizard enables you to assign a name to the current backup 
job. After a backup, the job name appears in the Last Operation field of the Device Table.  

 
Enter a name for the backup job in the Job Name field.  

When you have entered a name for the backup job, click Next. The Backup Wizard continues 
with the Backup Wizard - Period Parameters Screen.  

 

Backup Wizard - Period Parameters Screen  
The Period Parameters screen of the Backup Wizard enables you to configure the frequency and 
time of periodic backups.  

To configure the frequency and time of backups:  

1. Select an hour from the Start Hour pull-down list box to configure the start time for the 
backup job. 

2. Select an option button in the Recurrence Pattern section of the dialog box to configure 
the basis of the recurrence pattern. Possible options are:  

¡ Daily - The backup job will be performed every x days.  

¡ Weekly - The backup job will be performed every x weeks.  

¡ Monthly - The backup job will be performed every x months.  

3. Finish configuring the recurrence pattern by doing one of the following:  

¡ If you selected the Daily option button, enter a number in the Every x Days field.  
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¡ If you selected the Weekly option button.  

 
a. Enter a number in the Every x Week(s) field.  

b. Check the checkboxes next to the days of the week on which you want 
the backup job to run.  
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¡ If you selected the Monthly option button.  

 
a. Enter a number in the Day x field. This is the day of the month on which 

the backup job will run. If the day does not exist in a given month, (e.g. 
the 30th day of February), the last day of the month will be substituted.  

b. Enter a number in the Every y Month(s) field.  

c. Enter a starting date in the Start Date field. 

d. Select an end of the recurrence range for the backup job. Possible range 
ends are:  

¡ No end date - The backup job runs until it is deleted.  

¡ End after x occurrences - Enter a number. The backup job runs 
x times, where x is the number entered.  

¡ End by - Enter a date. The backup job runs until the date 
entered.  

When you finish configuring the period parameters for the backup job, click Next. The Backup 
Wizard continues with the Backup Wizard - Summary Screen.  
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Backup Wizard - Summary Screen  
The Summary screen of the Backup Wizard displays a summary of the backup job configured 
using the previous screens.  

 

To make any changes to the summary information:  

1. Click Back until you reach the appropriate screen. 

2. Change the backup job's parameters. 

3. Click Next until you reach the Summary screen. 

To start the backup job with the configured parameters, click Submit.  
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Downloading Configuration Files 
Downloading Configuration Files  

This section of the on-line help explains how to download configuration files to the devices in the 
Device Table. It includes the following sections:  

• Using the Library View - Describes the Library View Table. 
• Downloading - Provides instruction on how to download a configuration file to a device. 
• Editing Configuration Files - Instructions on how to edit configuration files using the 

Configuration Editor. 

  See Also  
• Managing Jobs - Instructions on how manage jobs created by the Backup Wizard or the 

Restore Wizard. 
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Using the Library View  
This section describes the information in the Library View and explains how to filter the 
configuration files displayed in the Library Table. It includes the following topics:  

• The Library Table - Explains the information displayed in the various columns of the 
Library Table. 

• Filtering the Library Table - Explains how to filter out files in the Library Table. 

The Library Table  
The Library Table lists the configuration files in the library. The Library Table is used for 
downloading configurations to appropriate devices.  

The Library Table displays the following information about each file in the library:  

• Name/Desc - Name of the device (from the platform) from which the file was uploaded. 
• IP - IP address of the device from which the file was uploaded. 
• Module - The slot in which the module is located in the device from which the file was 

uploaded. For stackable devices, this is the module's position in the stack.  
• Device Type - The type of device. 

• Software - The software version running on the device at the time of the file creation. 
• File Type - The file type. Indicates whether the file is a Running Configuration file or a 

Startup Configuration file. 
• Job Name - The name of the job that created the configuration file. 
• Time - The date and time at which the configuration file was created or last modified. 
• Created By - The source of the configuration file. Options are:  

¡ Upload - The configuration file was created by an immediate backup job.  

¡ Edit - The configuration file was created or modified using the File Editor.  

¡ Unknown - The source of the configuration file is unknown.  

• User - The name of the person who created or last modified the configuration file. 
• File - The command line interface (CLI) name of the configuration file. 

 Note: 

Files for Avaya Distributed Office are encrypted and cannot be edited, compared, 
or deleted. 

Filtering the Library Table  
By default, all of the configuration files in the library are displayed in the Library Table. Filtering 
the files displayed in the Library Table can help you focus on the files with which you want to 
work. 

When filtering, you can select: 

• Devices by name, IP address, or group.  
• Families of devices and specific module types. Under each product family name, one or 

more module types are listed. To display module types, click the handle next to the 
product family.  

When you select a product family, all the module types are automatically selected. You 
can then clear any module types that you do not want to select.  
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• Files by backup job name, date, and types. 

 

To filter the Library Table:  

1. Select Actions > Filter. The Filter dialog box opens. 

 
2. To filter by Select Criteria, enter the Device Name and/or IP address and/or select a 

group from the Select Group drop-down list. 

3. To filter by Device Type, check the checkboxes of the device and modules types you 
want to see in the Library Table. Clear the checkboxes of the device and module types 
you do not want to appear in the Library Table. To select all device and module types, 
check All. 
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4. To filter by File Types, check the checkboxes of the file types you want to see in the 
Library Table. Clear the checkboxes of the file types you do not want to appear in the 
Library Table. 

5. Click Apply. The filter is activated and the dialog box closes. 

6. When the filtering criteria are active,  appears in the Status Line.  
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Downloading  

 Note: 

When you download a file, the protocol used appears in the log. For information 
about configuring the download protocol, refer to The File Transfer Protocols Tab. 

 

To download a configuration file to one or more devices:  

1. In the Library Table, select the configuration file you want to download to one or more 
devices. 

2. Click the  (Download To Device) button on the Toolbar 

Or  

Select Actions > Download.  

The Download dialog box displays the file name and source and possible destinations for 
the file.  
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3. Select modules or devices to which you want to download the selected configuration file.  

The Possible Destinations list contains a list of all modules and devices to which it is 
appropriate to download the selected configuration file. The configuration file is only 
downloaded to modules and devices in the Selected Destinations list.  

¡ To add modules or devices to the Selected Destinations list:  

a. Select modules or devices in the Possible Destinations list.  

b. Click . The selected modules or devices are added to the Selected 
Destinations list.  
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¡ To add all of the modules or devices in the Possible Destinations list to the 

Selected Destinations list, click . All of the modules or devices in the 
Possible Destinations list are added to the Selected Destinations list. 

¡ To remove modules or devices from the Selected Destinations list:  

a. Select modules or devices in the Selected Destinations list.  

b. Click . The selected modules or devices are removed from the 
Selected Destinations list.  

¡ To remove all of the modules or devices from the Selected Destinations list, click 

. All of the modules or devices in the Possible Destinations list are 
removed from the Selected Destinations list. 

4. Configure the reset after download option. 

Some devices need to be reset after a download in order for the downloaded 
configuration to take effect. Using the Download dialog box, you can instruct the device to 
be reset when the download is completed.  

¡ To automatically reset the device after the download, check the Reset After 
Download checkbox.  

¡ If you do not want the device to reset after the download, clear the Reset After 
Download checkbox.  

5. Click Download. The Download Confirmation dialog box opens. 

 

 Note: 

If Default Action When Downloading is configured to Do Not Request 
Confirmation, the Download Confirmation dialog box does not open. 

¡ If the modules or devices in the Selected Destinations list exactly match the 
module or device from which the configuration file was uploaded, a confirmation 
dialog box opens with information about the configuration file and the selected 
devices.  
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¡ If the modules or devices in the Selected Destinations list do not exactly match 
the module or device from which the configuration file was uploaded, a warning 
message appears at the bottom of the dialog box. For example, this can occur 
when the device types are the same, but the modules or devices have different 
expansion modules or when a configuration file has been edited manually.  

¡ To download the configuration file to the selected device, click Proceed. The 
selected configuration file is downloaded to the modules or devices in the 
Selected Destination list.  

 Note: 
Once the download process begins, it cannot be stopped. 

 Caution: 
If an inappropriate configuration file is downloaded to a module or 
device, you may lose contact with the device's agent. 

¡ To edit the configuration file with the Configuration Editor, click Edit file. The 
Configuration Editor opens. After editing the file, you can initiate the download 
process from the Configuration Editor. For more information on the Configuration 
Editor, refer to Editing Configuration Files.  

¡ To cancel the download, click Cancel. The download is cancelled.  

6. If the configuration was manually edited, the Download Warning dialog box opens. 

 
7. To download the file, click Yes. The file is downloaded to the selected devices. To cancel 

the download, click No. 
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Creating a Restore Job 
The Restore Wizard provides a simple method of restoring the configurations of one or more of 
the devices in your network. You can perform immediate restores to solve problems or schedule 
delayed restores during convenient off hours  

 Note: 

If you configure a restore job from a workstation working via remote access, the 
backup files must have been saved on the server. 

• Activating the Restore Wizard 
• Restore  Wizard Screens 

Activating the Restore Wizard  
To create a new restore job:  

Click the  (Restore Wizard) button on the Toolbar  

Or  

Select Actions > Restore. The Restore Wizard opens with the Restore  Wizard - 
Welcome Screen.  

To edit an existing restore job:  

You cannot edit an existing restore job. Instead, delete the job and then recreate it with 
the changed information. 

Restore Wizard Screens  
This section provides detailed information on each of the Restore Wizard's screens. To accept 
the default options for any screen, click Next. To return to an earlier screen, click Back. To exit 
the Restore Wizard without making any changes, click Cancel.  

The following sections describe each of the Restore Wizard screens.  

• Restore Wizard - Welcome Screen 
• Restore Wizard - Search Devices Screen 
• Restore Wizard - Search Files to Restore Screen 
• Restore Wizard - Select Files Screen 
• Restore Wizard - Execution Details Screen 

• Restore Wizard - Restore Job Summary Screen 
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Restore Wizard - Welcome Screen  
The Restore Wizard provides a simple method for restoring or loading the configurations of 
devices in your network .  

 
To continue, click Next. The Restore Wizard continues with the Restore Wizard - Search 
Devices Screen.  

 

Restore Wizard - Search Devices Screen  

The Search Devices screen of the Restore Wizard enables you to locate eligible devices that can 
be restored from the backup files selected in the Library Table. You can use the Select Criteria 
and Device Type fields to narrow the possible choices. 
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To narrow the range of eligible devices to restore:  

• Specify Device Name, IP Address, and/or select a group from the Select Group drop-
down list. 

• Specify Device Type by checking the checkboxes for specific device families or devices. 

When you have selected a method for device selection, click Next. The Backup Wizard continues 
with the Restore Wizard - Search Files to Restore Screen.  

 

Restore Wizard - Search Files to Restore Screen  
The Search Files to Restore screen of the Restore Wizard enables you to specify the name of the 
backup job that created the files to be restored, and specify the types of files to restore..  

 
Enter a Backup Job Name to select files from that backup. Select files by date if desired. Check 
the File Types to restore. 

Click Next. The Restore Wizard continues with the Restore Wizard - Select Files Screen.  
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Restore Wizard - Select Files Screen  
The Select Files screen of the Restore Wizard enables you to select which versions of files will be 
restored.  

 
When you have selected files, click Next. The Restore Wizard continues with the Restore 
Wizard - Execution Details Screen.  

 

Restore Wizard - Execution Details Screen  

The Execution Details screen of the Restore Wizard enables you to assign a name to the restore 
job and specify whether the job is to run immediately or at a later time.  

 
Enter a name for the restore job in the Job Name field. (A name will be generated if you do not 
specify one.) Select an immediate or scheduled execution time. Click on "..." to set date and time 
for scheduled execution. Clear the checkbox for Reset if you do not want to automatically apply 
the changes when downloaded. 
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When you click Next, the Restore Wizard continues with the Restore Wizard - Restore Job 
Summary Screen.  

 

Restore Wizard - Restore Job Summary Screen  
The Summary screen of the Restore Wizard displays a summary of the restore job configured 
using the previous screens.  

 
   

To make any changes to the summary information:  

1. Click Back until you reach the appropriate screen. 

2. Change the Restore job's parameters. 

3. Click Next until you reach the Summary screen. 

To start the restore job with the configured parameters, click Finish.  
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Editing Configuration Files 
Editing Configuration Files  

Avaya Network Configuration Manager provides the ability to edit configuration files manually. 
The Configuration Editor is a simple text editor that opens with the selected configuration file. 
Each line of a configuration file corresponds to a single CLI (command line interface) command. 
For information on CLI commands, refer to the device's User's Guide.  

 Note: 

Not all configuration files are editable. Configuration files for Avaya Distributed 
Office are encrypted and cannot be edited. 

You can also add comments to a configuration file. Any line starting with the characters '!#' is 
taken to be a comment and is ignored by the device.  

Configuration files contain important information about the configuration of a device. If a 
configuration file contains inappropriate instructions for a device, it may impair the functioning of 
the device. Therefore, it is advisable to use the Configuration Editor only when making minor 
changes to configuration files.  

 Caution: 

Avaya Network Configuration Manager cannot verify the reliability of edited 
configuration files. Therefore, a warning dialog box appears every time you 
attempt to download a configuration that was edited manually. If you download a 
configuration file that has errors or is not appropriate for the device to which you 
download it, you may lose contact with the device's agent. 

See Also 
• The Configuration Editor User Interface 

• Saving Configuration Files 
• Downloading Edited Files 
• Closing the Configuration Editor 
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The Configuration Editor User Interface 
The Configuration Editor User Interface  

 

The Configuration Editor consists of the following components:  

• Menu Bar - Menus for accessing all Configuration Editor functions. 
• Configuration Editor Toolbar - Toolbar buttons for accessing most of the Configuration 

Editor's functions. 
• Editing Window - A window where the text of the configuration file appears and can be 

edited. 
• Status Bar - An area at the bottom of the Configuration Editor where information about 

the file being edited is displayed. 
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Configuration Editor Menus  
The following menus are available in the Configuration Editor.  

File Menu  

Item Description 

Save Opens the Save Configuration File dialog box. 

Close Closes the Configuration Editor.  

 

Edit Menu  

Item Description 

Cut Cuts the selected text to the clipboard. 

Copy  Copies the selected text to the clipboard.  

Paste Pastes the text from the clipboard.  

Undo Undoes the most recent action in the Configuration Editor.  

Redo Reverses the last undo action in the Configuration Editor.  

 

Action Menu  

Item Description 

Download Opens the Download Configuration dialog box.  

 

Help Menu  

Item Description 

Contents Opens the help module contents page for information. 

Help On  Opens the help module contents for context-sensitive on-line help. 
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Configuration Editor Toolbar  
The Configuration Editor toolbar provides shortcuts to the main Configuration Editor functions.  

The table below describes the buttons on the Configuration Editor toolbar and gives the 
equivalent menu options. 
  

Button Description  Menu Item  

 

Saves the edited 
configuration file.  

File > Save  

 

Undoes the last action.  Edit > Undo  

 

Cuts the selected text to the 
clipboard.  

Edit > Cut  

 

Copies the selected text to 
the clipboard.  

Edit > Copy  

 

Pastes the selected text from 
the clipboard.  

Edit > Paste  

 

Opens the Download dialog 
box with the edited 
configuration.  

Action > Download  

 

Opens context-sensitive on-
line help.  

Help > Help On  
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Editing Window  
The Editing Window is the area where you edit the configuration file. You can edit a configuration 
file in the same manner you edit any text file. Text is entered using the keyboard and can be cut, 
copied, or pasted from within the Configuration Editor and from external text editing applications.  

 

To cut text to the clipboard:  

1. Select the text you want to cut to the clipboard. 

2. Click . 

Or  

Select Edit > Cut. The selected text is cut to the clipboard.  

 

To copy text to the clipboard:  

1. Select the text you want to copy to the clipboard. 

2. Click . 

Or  

Select Edit > Copy. The selected text is copied to the clipboard.  

 

To paste text from the clipboard:  

1. Put the cursor where you want the text inserted. 

2. Click .  

Or 

Select Edit > Paste. The selected text is pasted from the clipboard.  

 

  



Avaya Network Configuration Manager On-Line Help Printout 

62 

 

Status Bar  
The Status Bar displays the following information:  

• The Type of device from which the original configuration file was uploaded. 
• The IP address of the device from which the original configuration file was uploaded. 
• The Module number of the device from which the original configuration file was 

uploaded. 
• The Date the original configuration file was uploaded. 

• An indicator showing whether the file was edited but not yet saved. If the configuration file 
in the Configuration Editor was edited but not yet saved, modified appears in the 
Configuration editor Status Bar. 
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Saving Configuration Files  
To save a new or edited configuration file:  

1. Click  

Or  

Select File > Save. The File Description dialog box opens.  

 
2. Enter a description for the configuration file. 

3. Click OK. The configuration file is saved with a version number appended to the 
filename. This prevents older versions of the file from being removed from the library. The 
new file appears in the Library Table. 
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Downloading Edited Files  
If a configuration file was opened from the Download dialog box (refer to Downloading), you can 
return to the Download dialog box directly from the Configuration Editor. To download the edited 
configuration file to a device:  

Click   

Or  

Select Actions > Download. The Download dialog box opens.  

For more information on downloading, refer to Downloading.  
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Closing the Configuration Editor  
To close the Configuration Editor, select File > Close.  

The Configuration Editor closes.  
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Managing Jobs  
The Scheduled Jobs dialog box enables you to manage backup and restore jobs created with the 
Backup Wizard or Restore Wizard. Using the Scheduled Jobs dialog box, you can create, edit, 
and delete backup jobs and delete existing restore jobs. 

 

To view scheduled jobs: 

Click the  (Scheduled Jobs) button on the Toolbar 

Or 

Select Actions > Jobs. The Scheduled Jobs dialog box opens. 

 
The top of the Scheduled Jobs dialog box contains a list of all scheduled periodic backup and 
scheduled restore jobs configured on the network. The following table provides a list of the fields 
in the Jobs dialog box and their descriptions. 

 

Field Description 

Name The name of the backup or restore job. Restore job names are 
generated and begin with "Restore." 

Next Backup The date and time at which the backup job is scheduled to run 
next. Contains "None" for restore jobs. 

Period The basis for the recurrence pattern of the job. Possible periods 
are:  

• Daily - The backup is performed every x days. 
• Weekly - The backup is performed every x weeks. 

• Monthly - The backup is performed every x months. 
• Restore - A one-time scheduled restore job. 

Devices A list of the names of devices backed up or restored.  

User The name of the person who created or last modified the backup or 
restore job. 

 

To create a new backup job, click New job. The Backup Wizard opens with the Backup Wizard - 
Welcome Screen.  
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Note: 

Restore jobs cannot be created using the New Job button. Start the Restore Wizard to 
create a new restore job. 

 

To edit a backup job:  

Note: 

Restore jobs cannot be edited using the Edit button. Delete the job and then start the 
Restore Wizard to create a new restore job. 

1. Select a job from the list of jobs. 

2. Click Edit. The Backup Wizard opens with the Backup Wizard - Device Selection 
Screen. The parameters of the selected backup job appear in the Backup Wizard 
screens. 

 

To delete a backup or restore job:  

1. Select a job from the list of jobs. 

2. Click Delete. A confirmation dialog box opens. 

3. Click Yes. The job is deleted. 

   

 


